Password Reset

Problem

Can't log into MyApps, invalid password or username.

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Environment

MyApps / SSO

Resolution

1. Open your preferred web browser and navigate to northeast.edu

2. At the top right of the webpage, click on Students

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3. Click on Access MyApps

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4. Type your college email where it says Northeast Email Address

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5. Click on Forgot my password

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6. Enter the characters in the picture or words in the audio. 

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7. Click Next. After clicking next follow the on screen instructions to verify your identity and reset your password. 

If you receive a message that says you must "register for self-service password reset", contact the service center with your Full Name, Date of Birth, last 4 of your SSN. In the ticket let them know you were resetting your password and it said you must register for self service password reset. Provide a phone number or email for them to add to your account.

 

Password Requirments

-Cannot be one of your last 4 passwords

-Cannot contain any part of your Full Name or Northeast email

-Must contain one uppercase letter (A-Z), one lowercase letter (a-z), one number (0-9), and one special character (~!@#$%^&*_-+=`|\(){}[]:;"'<>,.?/)

-Must be at least 12 characters long

Cause

Passwords expire every 365 days and/or will be required if you lock out your account.

Details

Article ID: 209
Created
Thu 7/28/22 12:50 PM
Modified
Tue 2/27/24 8:35 AM