Problem
Can't log into MyApps, invalid password or username.
Environment
MyApps / SSO
Resolution
1. Open your preferred web browser and navigate to northeast.edu
2. At the top right of the webpage, click on Students
3. Click on Access MyApps
4. Type your college email where it says Northeast Email Address
5. Click on Forgot my password
6. Enter the characters in the picture or words in the audio.
7. Click Next. After clicking next follow the on screen instructions to verify your identity and reset your password.
If you receive a message that says you must "register for self-service password reset", contact the service center with your Full Name, Date of Birth, last 4 of your SSN. In the ticket let them know you were resetting your password and it said you must register for self service password reset. Provide a phone number or email for them to add to your account.
Password Requirments
-Cannot be one of your last 4 passwords
-Cannot contain any part of your Full Name or Northeast email
-Must contain one uppercase letter (A-Z), one lowercase letter (a-z), one number (0-9), and one special character (~!@#$%^&*_-+=`|\(){}[]:;"'<>,.?/)
-Must be at least 12 characters long
Cause
Passwords expire every 365 days and/or will be required if you lock out your account.