Password Reset

Problem

Can't log into MyApps, invalid password or username.

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Environment

MyApps / SSO

Resolution

1. Open your preferred web browser and navigate to Northeast Community College Microsoft Login

2. Type your college email where it says Northeast Email Address and click Next

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5. Click on Forgot my password

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6. Enter the characters in the picture or words in the audio. 

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7. Click Next. After clicking next follow the on screen instructions to verify your identity and reset your password. 

If you receive a message that says you must "register for self-service password reset", please fill out this Request Form and provide the following information.

  • Set the Short Description field to 
    • Need to register for self-service password reset
  • Add the following information to the Description field
    • Your Full Name
    • Date of Birth
    • Last 4 of your SSN
    • Phone number or email to add to your account

For assistance over the phone, please call (402) 844-4357 to reach our Service Center.

 

Password Requirments

-Cannot be one of your last 4 passwords

-Cannot contain any part of your Full Name or Northeast email

-Must contain one uppercase letter (A-Z), one lowercase letter (a-z), one number (0-9), and one special character (~!@#$%^&*_-+=`|\(){}[]:;"'<>,.?/)

-Must be at least 12 characters long

Cause

Passwords expire every 365 days and/or will be required if you lock out your account.